64-bit Library "LiveAmpLib2" could not be loaded

This forum deals with BCI2000 configuration issues.
Post Reply
minmin
Posts: 3
Joined: 16 Mar 2018, 19:09

64-bit Library "LiveAmpLib2" could not be loaded

Post by minmin » 17 Mar 2018, 16:26

Hi,

I use BCI2000 V3.6.beta.x32.extensions.

The following Steps:
1. Launched the BCI2000Launcher.exe, select LiveAmpSource, P3SingleProcessing, P3speller.
2. Config,add the P3Speller_CopySpelling.prm.
3. Set config, it halted with the error in the attachment.

the system log says:

2018-03-17T15:16:38 - BCI2000 Started.
2018-03-17T15:16:38 - SignalSource: Waiting for configuration ...
2018-03-17T15:16:39 - SignalProcessing: Waiting for configuration ...
2018-03-17T15:16:40 - Application: Waiting for configuration ...
2018-03-17T15:17:13 - Operator set configuration.
2018-03-17T15:17:13 - SignalSource warning, DataIOFilter::Preflight:
The VisualizeSourceTime parameter specifies time without unit. Throughout BCI2000, time specifications without unit are now consistently interpreted as being given in sample blocks.
If your source display appears strange, try appending the letter "s" to the VisualizeSourceTime parameters value.
2018-03-17T15:17:13 - SignalSource error, DataIOFilter::Initialize: LiveAmpADC::Initialize:
64-bit Library "LiveAmpLib2" could not be loaded, but is necessary for LiveAmpSource to run.
You may need to install the driver software that came with your amplifier. More information may be available at:
http://www.google.com/search?q=site%3abci2000.org+LiveAmpLib2.
2018-03-17T15:17:13 - SignalProcessing: P3SignalProcessing initialized.
Attachments
Untitled.jpg

dmedine
Posts: 4
Joined: 06 Apr 2018, 03:26

Re: 64-bit Library "LiveAmpLib2" could not be loaded

Post by dmedine » 06 Apr 2018, 04:01

It looks like you have a 64-bit version of LiveAmpLib2.dll, but the BCI2000 distribution you have is a 32-bit one. Can you point me to where you downloaded this distribution?

minmin
Posts: 3
Joined: 16 Mar 2018, 19:09

Re: 64-bit Library "LiveAmpLib2" could not be loaded

Post by minmin » 12 Apr 2018, 11:35

The person who downloaded it is not me but I think it is from https://www.bci2000.org/bbs/viewtopic.php?f=1&t=2955

praveenpuvvadi
Posts: 4
Joined: 05 Nov 2017, 14:43

Re: 64-bit Library "LiveAmpLib2" could not be loaded

Post by praveenpuvvadi » 27 Apr 2018, 19:33

Hi dmedine,

I work with minmin on Liveamp integration with BCI2000. I have both 62-bit and 32-bit versions of BCI2000. I tried both and they give same warning when configures in operator. Let me know if you have any other solution

-Praveen

dmedine
Posts: 4
Joined: 06 Apr 2018, 03:26

Re: 64-bit Library "LiveAmpLib2" could not be loaded

Post by dmedine » 30 Apr 2018, 05:50

Can you confirm that you have a copy of LiveAmpLib2.dll in the folder <path_to>\BCI2000v3.6\prog

I can use the LiveAmp on my system without any issues. However, I have access tot he source code and have built everything from there. This is perhaps a bit different than the 3.6 beta release.

praveenpuvvadi
Posts: 4
Joined: 05 Nov 2017, 14:43

Re: 64-bit Library "LiveAmpLib2" could not be loaded

Post by praveenpuvvadi » 02 May 2018, 13:22

Thanks. resolved the issue. The problem is with the incompatible beta release. I have made it work for 32 channel liveamp. Did you use it for 64 channel too?

-praveen

Post Reply

Who is online

Users browsing this forum: Google [Bot] and 1 guest