Using OpenBCI

This forum deals with BCI2000 configuration issues.
Post Reply
ciaranglasgow
Posts: 2
Joined: 17 Sep 2020, 04:33

Using OpenBCI

Post by ciaranglasgow » 17 Sep 2020, 04:40

Hi,

I am trying to use OpenBCI's Cyton board with the latest version of BCI2000. I used the default parameters in CursorTask_OpenBCI_Module.bat but can't complete configuration when I click Set Config as it gets stuck on the following line: 'Query the board'. Presumably this means that although BCI2000 recognizes the OpenBCI dongle it can't receive data from the board itself.

I have tried manually defining port name, number of channels etc. but nothing seems to work...

Any other suggestions would be greatly appreciated. Please see the system log file below:

Thanks

2020-09-17T16:31:30 - BCI2000 Started.
2020-09-17T16:31:30 - Started "OpenBCI_Module".
2020-09-17T16:31:30 - SignalSource: Waiting for configuration ...
2020-09-17T16:31:30 - Started "DummySignalProcessing".
2020-09-17T16:31:30 - SignalProcessing: Waiting for configuration ...
2020-09-17T16:31:30 - Started "CursorTask".
2020-09-17T16:31:30 - Application: Waiting for configuration ...
2020-09-17T16:31:31 - Loaded parameter file "C:/BCI2000/BCI2000 v3.6.R6143/BCI2000.x64.bundled/parms/examples/CursorTask_SignalGenerator.prm".
2020-09-17T16:31:31 - Loaded parameter file "C:/BCI2000/BCI2000 v3.6.R6143/BCI2000.x64.bundled/parms/fragments/amplifiers/OpenBCI_Module.prm".
2020-09-17T16:31:56 - Operator set configuration.
2020-09-17T16:31:56 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
Board RESET.
2020-09-17T16:31:56 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
OPEN PORT Finished!!
2020-09-17T16:31:56 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
PORT COM1 Connected Successfully!!
2020-09-17T16:31:56 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
BUFFER refreshed Successfully.
2020-09-17T16:32:00 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
PORT COM1 NO Handshake.
2020-09-17T16:32:00 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
Failed to Open Stream1 (Port Not Found!! i.e. File Descriptor value = NULL).
2020-09-17T16:32:00 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
PORT COM2 NO Connection!!!
2020-09-17T16:32:00 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
Board RESET.
2020-09-17T16:32:00 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
OPEN PORT Finished!!
2020-09-17T16:32:00 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
PORT COM3 Connected Successfully!!
2020-09-17T16:32:00 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
BUFFER refreshed Successfully.
2020-09-17T16:32:02 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
Communication Initialized 124.
2020-09-17T16:32:02 - SignalSource, DataIOFilter::AutoConfig: OpenBCI_ModuleADC::AutoConfig:
SourceCh SET automatically to 8 Channels.
2020-09-17T16:32:02 - SignalSource, DataIOFilter::Preflight: OpenBCI_ModuleADC::Preflight:
Number of Signal Channels = 8.
2020-09-17T16:32:02 - SignalSource, DataIOFilter::Preflight: OpenBCI_ModuleADC::Preflight:
Sample Block Size = 125.
2020-09-17T16:32:02 - SignalSource, DataIOFilter::Preflight: OpenBCI_ModuleADC::Preflight:
Sampling Rate = 250.
2020-09-17T16:32:02 - SignalProcessing: DummySignalProcessing initialized.
2020-09-17T16:32:03 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Board RESET.
2020-09-17T16:32:03 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
SET the board to Default Channel settings.
2020-09-17T16:32:03 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Streaming Stopped.
2020-09-17T16:32:03 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Flush buffer.
2020-09-17T16:32:03 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Using 8 Channel Mode.
2020-09-17T16:32:03 - Application: CursorTask initialized.
2020-09-17T16:32:04 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 1 out of 8 has been completed.
2020-09-17T16:32:05 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 2 out of 8 has been completed.
2020-09-17T16:32:06 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 3 out of 8 has been completed.
2020-09-17T16:32:06 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 4 out of 8 has been completed.
2020-09-17T16:32:07 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 5 out of 8 has been completed.
2020-09-17T16:32:08 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 6 out of 8 has been completed.
2020-09-17T16:32:09 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 7 out of 8 has been completed.
2020-09-17T16:32:10 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Setting for Channel 8 out of 8 has been completed.
2020-09-17T16:32:10 - SignalSource, DataIOFilter::Initialize: OpenBCI_ModuleADC::Initialize:
Query the board.

mellinger
Posts: 1141
Joined: 12 Feb 2003, 11:06

Re: Using OpenBCI

Post by mellinger » 21 Sep 2020, 08:17

Hi,

have you had a look at this troubleshooting suggestion:
https://www.bci2000.org/mediawiki/index ... le#Issue_1

-Jürgen

ciaranglasgow
Posts: 2
Joined: 17 Sep 2020, 04:33

Re: Using OpenBCI

Post by ciaranglasgow » 22 Sep 2020, 05:04

Hello,

Thanks for your reply. Yes, I had a look. My PC doesn't have Bluetooth capability so it doesn't help, unfortunately.

I have had better luck using LSLSource to collect data from the Cyton board and encourage others to try this if you're struggling to connect through OpenBCI_Module.

Best,
Ciaran

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests