Visual Studio Debug Assertion Failure

This forum deals with BCI2000 configuration issues.
sumits
Posts: 18
Joined: 15 Nov 2011, 06:25

Visual Studio Debug Assertion Failure

Post by sumits » 14 Jun 2013, 01:13

I built BCI2000 from sources and was able to run batch files such as StimulusPresentation_SignalGenerator etc.

However, recently whenever I run any task, I get the following error message.
Error dialog on starting BCI2000 scripts
Error dialog on starting BCI2000 scripts
This is related to Visual Studio, I tried to rebuild the VS project as well as the script that generates the solution file but am still getting the same error. I am using 64-bit Windows 7 and Visual Studio 2008.

How can this be fixed? Any ideas?

mellinger
Posts: 1088
Joined: 12 Feb 2003, 11:06

Re: Visual Studio Debug Assertion Failure

Post by mellinger » 14 Jun 2013, 12:02

Hi,

sorry that you are having problems with the latest trunk code.
I'm currently working to stabilize the trunk version of BCI2000 on all supported platforms, and then switching core development to a proxy repository.

Hopefully, this will avoid major problems in the trunk for the future.
Bug fixes will still go into the trunk immediately, and may break compiles occasionally, but that will be easy to fix on an as-needed-basis.

For now, the only thing I can recommend is to checkout from svn/releases/current rather than from svn/trunk.

Regards,
Juergen

sumits
Posts: 18
Joined: 15 Nov 2011, 06:25

Re: Visual Studio Debug Assertion Failure

Post by sumits » 17 Jun 2013, 05:12

I am using the current version itself, from http://www.bci2000.org/svn/tags/releases/current.

Do let me know if any further information is required.

mellinger
Posts: 1088
Joined: 12 Feb 2003, 11:06

Re: Visual Studio Debug Assertion Failure

Post by mellinger » 17 Jun 2013, 10:39

Hi,

this might be related to a bug in VS2008. Please make sure to have Sp1 installed.
If that doesn't fix the problem, it would be interesting to know how to reproduce the bug.

Regards,
Juergen

SwarthBCI
Posts: 7
Joined: 10 Apr 2013, 11:03

Re: Visual Studio Debug Assertion Failure

Post by SwarthBCI » 17 Jun 2013, 12:30

Hi Juergen,

I encountered the same problem. I tried both SVN from the "svn/tags/releases/current" and the archived source http://www.bci2000.org/downloads/src/BCI2000src.txz. Neither works. For the svn version, I got the same error as sumits got. For the archived source, when I open the .sln file, there was an error and the OperaterQt project and anther project cannot be loaded correctly. So after rebuild, there was no Operater.exe file. I am using visual studio 2010 express (with SP1 installed) on 64 bit Windows 7.

Zhi

mellinger wrote:Hi,

this might be related to a bug in VS2008. Please make sure to have Sp1 installed.
If that doesn't fix the problem, it would be interesting to know how to reproduce the bug.

Regards,
Juergen

mellinger
Posts: 1088
Joined: 12 Feb 2003, 11:06

Re: Visual Studio Debug Assertion Failure

Post by mellinger » 17 Jun 2013, 12:47

Hi Zhi and Sumit,

the VS2010 compilation problem has been fixed today, but is unrelated to the failing assertion problem.
For the 3.0.5 release, the code from "svn/tags/releases/current" was compiled with VS2008, and tested without problems. However, I was using V7.0 of the Windows SDK, rather than the version being installed with VS2008.

As a side note: the "archived" source is actually a daily snapshot of the BCI2000 svn trunk, which may be downloaded in form of a txz archive. It is not "archived" in the sense of being "historical".

I suggest both of you to try the latest svn trunk version of the BCI2000 source code. It should work with both VS2008 and 2010, and both 32 and 64bit compilers.

Sorry for the inconvenience, and thanks for reporting the bugs.

Regards,
Juergen

SwarthBCI
Posts: 7
Joined: 10 Apr 2013, 11:03

Re: Visual Studio Debug Assertion Failure

Post by SwarthBCI » 17 Jun 2013, 14:09

Thank you Juergen for your prompt response. I will try that and let you know the result. By the way, whether the current "archive" version also works. I feel I'd like to use the "archive" one.

Zhi

SwarthBCI
Posts: 7
Joined: 10 Apr 2013, 11:03

Re: Visual Studio Debug Assertion Failure

Post by SwarthBCI » 17 Jun 2013, 14:23

I just tried the "archive" version with VC2010 express. It still does not work. Two projects cannot be loaded. See attached screenshot.
Attachments
Error.jpg

SwarthBCI
Posts: 7
Joined: 10 Apr 2013, 11:03

Re: Visual Studio Debug Assertion Failure

Post by SwarthBCI » 17 Jun 2013, 16:48

Hi Juergen,

I have tested the svn codes. With VC2008 express, it works fine. But with VC2010 express, the same error as found by Sumits remains.

Zhi

sumits
Posts: 18
Joined: 15 Nov 2011, 06:25

Re: Visual Studio Debug Assertion Failure

Post by sumits » 18 Jun 2013, 05:08

Hi,

Am able to build the VS2010 solution after checking out from http_nospam_www.bci2000.org/svn/tags/releases/current/. The batch files are running fine now.

However, the VS2008 project built from the SVN trunk now gives the following error message.
Error Message
Error Message
I am using CMake 2.8, 64-bit Windows 7 and Qt 4.6.3. I'm not able to figure out how to reproduce the bug, I was able to run the batch files initially but later this error comes persistently.

SwarthBCI
Posts: 7
Joined: 10 Apr 2013, 11:03

Re: Visual Studio Debug Assertion Failure

Post by SwarthBCI » 18 Jun 2013, 09:43

Yes, for my 2010 solution, it worked fine initially. But after a while, it showed the error window as Sumits posted at the very first post. Now, all the errors are related to the operater module.

Zhi

mellinger
Posts: 1088
Joined: 12 Feb 2003, 11:06

Re: Visual Studio Debug Assertion Failure

Post by mellinger » 18 Jun 2013, 10:37

There might be a bug in the Operator module related to storing and retrieving window positions in case you switch between multiple monitor configurations.

Try to delete the file BCI2000/prog/Operator.ini and see whether the problem persists.

HTH,
Juergen

mellinger
Posts: 1088
Joined: 12 Feb 2003, 11:06

Re: Visual Studio Debug Assertion Failure

Post by mellinger » 18 Jun 2013, 11:26

Qt 4.6.3
That may be a problem, as BCI2000 3.0.5 has been developed against Qt 4.7.0. You might try updating to the latest SVN trunk version, which comes with Qt 4.8.4 pre-built for MSVC compilers.

-Juergen

SwarthBCI
Posts: 7
Joined: 10 Apr 2013, 11:03

Re: Visual Studio Debug Assertion Failure

Post by SwarthBCI » 18 Jun 2013, 13:02

By deleting the Operator.ini file, the program works again. Thank you! By the way, is it possible to make the "archive" version work as well?

Zhi
mellinger wrote:There might be a bug in the Operator module related to storing and retrieving window positions in case you switch between multiple monitor configurations.

Try to delete the file BCI2000/prog/Operator.ini and see whether the problem persists.

HTH,
Juergen

mellinger
Posts: 1088
Joined: 12 Feb 2003, 11:06

Re: Visual Studio Debug Assertion Failure

Post by mellinger » 18 Jun 2013, 13:09

Hi,

the "archive" version is just a daily updated copy of the SVN trunk. It is updated each day around midnight GMT.

In case the bad Operator.ini is still in your trash, I would appreciate if you sent it to me in a private message. I've had some reports of such a bug, but never succeeded in reproducing it.

Best regards,
Juergen

Locked

Who is online

Users browsing this forum: No registered users and 2 guests