importing datafiles in BrainVisionAnalyzer

Locked
W. K. Kenbeek
Posts: 3
Joined: 17 Feb 2006, 05:25

importing datafiles in BrainVisionAnalyzer

Post by W. K. Kenbeek » 21 Feb 2006, 10:43

Hello,

For my experiment on a 2 dimensional BCI system I'm trying to import my data in BrainVisionAnalyzer. However, when using the BrainVisionImporter application from the BCI200 package, I get the following error:

"File format error in file C:\ .... \RHS003R01.dat:
'SourceCh' header entry does not match number of entries in 'SourceChGain' and 'SourceChOffset' "

How can I fix this problem? (Preferably without having to start all over with the measurement...)

Thanks for helping,

Wout Kenbeek

mellinger
Posts: 1098
Joined: 12 Feb 2003, 11:06

Post by mellinger » 21 Feb 2006, 12:21

Wout,

there is a less strict consistency check in the latest CVS version of the BrainVisionAnalyzer converter tool, i.e. if you update your source tree and recompile the converter tool, it will not report the error any more.

If recompiling is not an option, you might choose to modify the BCI2000 file header with a binary editor by
1) changing the number of entries, i.e. the first number after the equals sign, for the SourceChGain and SourceChOffset parameters to the value of the SoftwareCh parameter, and
2) removing redundant values from those two parameters at the end of the list before the // comment separator.

As the header may not change its length without breaking the file format, you will need to replace redundant values by space characters instead of deleting them from the file.

Regards,
Juergen

W. K. Kenbeek
Posts: 3
Joined: 17 Feb 2006, 05:25

VisionAnalyzer

Post by W. K. Kenbeek » 27 Feb 2006, 05:38

Dear Juergen Mellinger,

Thanks for helping for so far. I wasn't able to get the newest version of BDI2000 until now, but matching the number of entries in the datafile seems at least to get me to a next stage with new problems.

The next problem I was somehow able to solve: The number of datapoints was not an integer multiple of the blocksize. I just changed the SampleBlockSize to 1, so that any number would be an interger multiple:

"Source int SampleBlockSize= 1 0 0 0 // this is the number of samples transmitted at a time"

Now, the file at least survived the BrainVisionImporter, but the corresponding BrainVision markerfile was 47 Mb (!!!), while the original file was 5 Mb for a 4 minute measure with 8 channels. I guess that the size of this file makes that BrainVisionAnalyzer stuck when reading the raw data. So this is still quite a problem.

Do you know the answers?

thanks again,

Wout Kenbeek

mellinger
Posts: 1098
Joined: 12 Feb 2003, 11:06

Post by mellinger » 27 Feb 2006, 10:53

Dear Wout Kenbeek,

from the "not integer multiple of the data size" problem I suspect that you accidentally changed the file's header length when editing the SourceChGain and SourceChOffset parameters.

The very large marker file points into the same direction (random markers will require a lot more space than actual marker data for which the encoding is quite efficient).

Regards,
Juergen

Locked

Who is online

Users browsing this forum: No registered users and 1 guest