p3speller audio stimuli

Known Issues and Problems with BCI2000
Locked
ariel
Posts: 14
Joined: 30 Sep 2008, 09:49

p3speller audio stimuli

Post by ariel » 30 Sep 2008, 10:16

Hi:
We are using BCI2000 and trying to do experiments with audio P3Speller. We checked the "Audio Stimuli Mode", and used the audio stimuli files that comes with the program. The problem is that during the presentation of the stimulis some visual stimuli is not shown but are displayed auditory and vice versa.
Please expect a prompt reply, thank you very much.

mellinger
Posts: 1064
Joined: 12 Feb 2003, 11:06

Post by mellinger » 30 Sep 2008, 10:32

Ariel,

thanks for reporting this problem. It would be quite helpful if you could send me a parameter or data file for which this occurs:
juergen.mellingerNOSPAM_ATuni-tuebingen.de

Regards,
Juergen
Last edited by mellinger on 18 Mar 2010, 13:29, edited 2 times in total.

ariel
Posts: 14
Joined: 30 Sep 2008, 09:49

Post by ariel » 01 Oct 2008, 14:42

We use P3Speller_SignalGenerator.bat and check the audio stimuli box. What happens is that when the program is covering rows and columns sometimes skips the visual stimulus and other times skips the hearing stimuli.

mellinger
Posts: 1064
Joined: 12 Feb 2003, 11:06

Post by mellinger » 02 Oct 2008, 09:36

So you are starting up from P3Speller_SignalGenerator.bat, then load parms/examples/P3Speller_CopySpelling.prm, and additionally check the AudioStimuliOn parameter's checkbox?

ariel
Posts: 14
Joined: 30 Sep 2008, 09:49

Post by ariel » 02 Oct 2008, 11:00

We are starting up from P3Speller_SignalGenerator.bat, then load parms\p3_tutorial\InitialP3Session.prm, and check the AudioStimuliOn parameter's checkbox. The matrix`s size are set to 3x3. We are using the wav files wich are in \prog\sounds. The wav files: 1, 2, 3 are placed in AudioStimuliRowsFiles and 4, 5, 6 are placed in AudioStimuliColsFiles. Then we increase StimulusDuration to 500ms to test whether this function.

mellinger
Posts: 1064
Joined: 12 Feb 2003, 11:06

Post by mellinger » 02 Oct 2008, 12:43

Ariel,

I identified a bug in the P3Speller application that would incorrectly associate audio stimuli with rows and columns, such that there would not be an audio stimulus for the first row, and the second column.

This bug is fixed now in the BCI2000 source code, and the fix will enter into the October build of BCI2000, which is due in some days, and will be available for download at
http://www.bci2000.org/wiki/index.php/BCI2000_Binaries

Again, thanks for your helpful bug report.

Regards,
Juergen

ariel
Posts: 14
Joined: 30 Sep 2008, 09:49

Post by ariel » 02 Oct 2008, 21:36

Juergen,

Thanks for solving the problem. We will continue with the experiment.

Locked

Who is online

Users browsing this forum: No registered users and 1 guest