BCI Launcher error

Known Issues and Problems with BCI2000
Locked
Jeremy
Posts: 4
Joined: 22 Aug 2008, 09:46

BCI Launcher error

Post by Jeremy » 22 Aug 2008, 09:55

Hi,

I've been using BCI2000 for a couple month now on the computer at my univeristy, and recently decided to install it on my home computer.

I have downloaded the source code with TortoiseSVN and I compiled the "project group". Everythng went well, but the Launcher gives me an error message:
"Error reading ActionManager1->StyleName: Property StyleName does not exist."

I tried recompiling just the launcher, but when I open the project, it says that it cannot create the form because of an inexisting ActionManager1->StyleName.

If I choose to ignore the error, I can compile it but without any changes to this first problem. If I choose to not ignore the error, then the form is not loaded...

I tried finding where the code calls this StyleName field, but it doesn't.

I have no idea where this is coming from.
I have the latest revision.

Thanks in advance

Jeremy, student @University of Geneva

jawilson
Posts: 109
Joined: 28 Feb 2005, 16:31

Post by jawilson » 22 Aug 2008, 10:56

Hello,
I wrote and maintain this program. The problem is due to an incompatibility between Borland 6 and Borland 2007, which introduces a component called XPStyleActnCtrls automatically into the code. After doing this, it will compile with borland 2007, but give this error in borland 6.
I am going to change the program so that it does not depend on this component at all. I will post here again within a few hours when it is working.
Adam

jawilson
Posts: 109
Joined: 28 Feb 2005, 16:31

Post by jawilson » 22 Aug 2008, 12:42

Jeremy,
This problem should be fixed now. I do not have Borland 6 installed, so I cannot test it with that, so let me know if the problem persists, or others are created with this fix. It works fine on my system with Borland 2007.
Adam

Jeremy
Posts: 4
Joined: 22 Aug 2008, 09:46

Post by Jeremy » 22 Aug 2008, 14:45

Wow!

Thanks a lot for this quick answer and correction!

It works now, but just so you know, I had a warning about an unused variable "proc" in the file "SIGRFRIED_UI.cpp" line 274.

Thanks again,

Jeremy

Locked

Who is online

Users browsing this forum: No registered users and 1 guest