EEG source visualization speed

Known Issues and Problems with BCI2000
Locked
nadoona
Posts: 14
Joined: 10 Aug 2007, 15:31

EEG source visualization speed

Post by nadoona » 16 Oct 2007, 16:41

Hi,

I noticed a strange thing in the EEG source in BCI 2000. The EEG source visualization cursor is not moving with a constant speed. The window that appear in the visualization window is 2 seconds; however, sometimes all of a sudden the cursor moves much faster than that rate. Then after a while, it moves with the normal rate again. This keeps repeating over and over.

Please advise,
Thanks.

gschalk
Posts: 615
Joined: 28 Jan 2003, 12:37

Source display speed

Post by gschalk » 16 Oct 2007, 19:52

Nadoona,

From what you describe, it is possible that you are running a BCI2000 configuration that uses close to 100% of the processor. Please check in the Task Manager what the processor load is. It should be below 50%. In typical configurations, it's between 5-10%. If it is close to 100%, perhaps you are digitizing at really high rates. In this case, set VisualizeSourceDecimation to a higher number. Perhaps you are 'clocking' BCI2000 at a rate that is too high. This is determined by how large SampleBlockSize is in relationship to SampleRate. E.g., at a SampleBlockSize of 10 and a SampleRate of 1000Hz, the system would update the displays, cursor movement, signal processing, etc., 100 times per second.

Gerv

nadoona
Posts: 14
Joined: 10 Aug 2007, 15:31

Post by nadoona » 17 Oct 2007, 02:41

The sampling rate is 256 Hz and the sample block size is 32 or 64. So I think 4 or 8 updates per second should not cause that problem.

Please advise.

PS. Im using mobilab as the data acquisition source.

Thanks.

gschalk
Posts: 615
Joined: 28 Jan 2003, 12:37

Processor Speed

Post by gschalk » 17 Oct 2007, 08:03

Nadoona,

What is the overall Processor Load? What is the Processor Load of each module?

Gerv

Locked

Who is online

Users browsing this forum: No registered users and 2 guests