Page 1 of 1

P300 calibration - text not advancing

Posted: 14 Jul 2021, 22:29
by rschmaelzle
Hello,
I've been tinkering with the p300 speller via LSL, which worked quite well, except for one critical issue:
The "to be spelled" text is not advancing. For instance, I am trying to spell THE, and the window shows me THE (T), suggesting that I should select the Ts. All is flashing as it should, but it never jumps from the (T) to an (E), which I suppose it should.
I am working with the latest version. However, one peculiarity might be that I am working on a MAC via parallels. However, all is working well, and the LSL crosstalk from Mac (where I am acquiring the EEG) and the virtual Windows10 isn't an issue at all. I see nice signals and all -- the only issue is just the advancing (I am in copy mode and am otherwise following the tutorial as close as I can).
Any ideas are appreciated.
Thanks a ton, Ralf.

Re: P300 calibration - text not advancing

Posted: 15 Jul 2021, 13:33
by mellinger
Hi,

I don't know which parameters you are using, so I tried the P3Speller_SignalGenerator.bat file, and it works fine for me. Could you try this and maybe double check your parameters?

HTH,
Juergen

Re: P300 calibration - text not advancing

Posted: 20 Apr 2022, 10:16
by adcass
I'm having the same issue - have double checked with the signal generator batch file, and the parameters work fine. I'm working directly on Windows 11, not going through any emulators. Double checked that the device is connected, which it is, and that LSL is appropriate, which it should be for ENOBIO8. Does anyone know what is going wrong?

Re: P300 calibration - text not advancing

Posted: 20 Apr 2022, 10:20
by mellinger
Hi, can you post the contents of the batch file you are using?
Thanks,
J├╝rgen

Re: P300 calibration - text not advancing

Posted: 20 Apr 2022, 10:32
by adcass
#! ../prog/BCI2000Shell
@cls & ..\prog\BCI2000Shell %0 %* #! && exit /b 0 || exit /b 1\n
#######################################################################################
## $Id: P3Speller_SignalGenerator.bat 4126 2012-06-15 17:42:57Z mellinger $
## Description: BCI2000 startup Operator module script. For an Operator scripting
## reference, see
## http://doc.bci2000.org/index/User_Refer ... _Scripting
##
## $BEGIN_BCI2000_LICENSE$
##
## This file is part of BCI2000, a platform for real-time bio-signal research.
## [ Copyright (C) 2000-2020: BCI2000 team and many external contributors ]
##
## BCI2000 is free software: you can redistribute it and/or modify it under the
## terms of the GNU General Public License as published by the Free Software
## Foundation, either version 3 of the License, or (at your option) any later
## version.
##
## BCI2000 is distributed in the hope that it will be useful, but
## WITHOUT ANY WARRANTY
## - without even the implied warranty of MERCHANTABILITY or FITNESS FOR
## A PARTICULAR PURPOSE. See the GNU General Public License for more details.
##
## You should have received a copy of the GNU General Public License along with
## this program. If not, see <http://www.gnu.org/licenses/>.
##
## $END_BCI2000_LICENSE$
#######################################################################################
Change directory $BCI2000LAUNCHDIR
Show window; Set title ${Extract file base $0}
Reset system
Startup system localhost
Start executable LSLSource --local
Start executable DummySignalProcessing --local
Start executable P3Speller --local
Wait for Connected

Re: P300 calibration - text not advancing

Posted: 20 Apr 2022, 11:19
by mellinger
There is an error in the batch file. Replace "DummySignalProcessing" with "P3SignalProcessing", and it should work.