Error compiling the Emotiv module

Known Issues and Problems with BCI2000
Post Reply
dinuka
Posts: 1
Joined: 15 Oct 2017, 06:14

Error compiling the Emotiv module

Post by dinuka » 16 Oct 2017, 03:27

Hi,
I downloaded the BCI2000 and I need to connect the Emotiv epoc. I downloaded the Emotiv module written by Griffin Milsap (griffin.milsap@gmail.com).

But when using cMake and trying to build the solution files it gives following error,

Code: Select all

 -- Selecting Windows SDK version  to target Windows 10.0.10586.
CMake Error at CMakeLists.txt:21 (BCI2000_INCLUDE):
Unknown CMake command "BCI2000_INCLUDE".


CMake Warning (dev) in CMakeLists.txt:
No cmake_minimum_required command is present.  A line of code such as

cmake_minimum_required(VERSION 3.10)
Please let me know if there are steps i have missed before running cmake and how can i fix these errors?
Here cmake cannot identify the function call or something ->

Code: Select all

BCI2000_INCLUDE( "SOURCEFILTER" )

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests