3 gtec, too slow!

Known Issues and Problems with BCI2000
Locked
gcisotto
Posts: 12
Joined: 27 Nov 2013, 03:44

3 gtec, too slow!

Post by gcisotto » 22 Jul 2014, 21:17

Dear all,

I am setting up an experiment with 3 gUSBamp amplifiers for a mu rhythm BCI acquisition, but visualization of EEG traces and of the user interface (both in the stimulus presentation and the cursor task case) dramatically slowes down if I connect more than one amplifier. With two of them I can already realized the delay by eye and with 3 of them delay is even more, around 5 or 6 seconds. What should it be due to? What can I do to delete this delay?

Thank you,
Giulia

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: 3 gtec, too slow!

Post by boulay » 23 Jul 2014, 07:33

Do you have them connected to each other through sync out (the master) and sync in (the other two)? I once had this cable in but not all the way and I had the same problem.
Also be sure that BCI2000 has the correct device set as the master.

gcisotto
Posts: 12
Joined: 27 Nov 2013, 03:44

Re: 3 gtec, too slow!

Post by gcisotto » 23 Jul 2014, 09:47

Thanks for answer Chad! (since I am currently researching at Keio University, at Ushiba Lab, I know you by name! ;) )
By the way, I will check again, but I have already checked many times, both cables and order of devices..
Any other ideas?

Thanks,
Giulia

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: 3 gtec, too slow!

Post by boulay » 23 Jul 2014, 10:32

Hello Giulia, it is nice to meet you.

I had the "too slow" problem in the Ushiba lab a few times. Once, I checked the parameters 20 times, I looked at the cables, everything was correct but it was still slow! Then I unplugged the cables and plugged them back in and the problem was gone (not slow anymore). My guess is that one of their sync cables is maybe a little loose. Try changing cables if you can. There is the one adapter that has the 1 master and 3 slaves (I think they have 2 of these), but you can also chain together amplifiers using the smaller cables (with one end saying "sync out" and the other saying "sync in") by going from device 1->2, 2->3, so you need two such cables.

In the parameter file, it is important that you correctly enter all of your amps by ID (DeviceIDs) and that you correctly enter the ID of the master (DeviceIDMaster). I think I have had better luck using the true ID of the master instead of using 'auto'.

More info here.

One more thought: when using multiple g.USBamps with BCI2000 it can be a little tricky to specify which channels come from which device, especially if you will have empty inputs for the first or second device. For example, if you are combining a 30-channel EEG cap and 8 EMG electrodes then you should use the first two devices for EEG and the third device for EMG... but what do you do with channels 31 + 32? It is possible to get this to work properly but it can be tricky. Let me know if this is the case for you then I will try to help more. If you are not skipping any channels (e.g. 31+32) then this is less of an issue.

gcisotto
Posts: 12
Joined: 27 Nov 2013, 03:44

Re: 3 gtec, too slow!

Post by gcisotto » 24 Jul 2014, 11:34

Hi Chad, it is nice to meet you too! ;)

Today I made a new tentative and I succeeded! I took care of each of the cables I used and, moreover, I selected 3 gUSBamp of the same kind (UA 2007).
That seemed properly work for the moment, so I was really lucky, let's see in future!
Actually yes, my purpose is to use all 32 channels for EEG from the first two amplifiers (master and first slave) and only a part of the third gUSBamp to record few, e.g. 2 or 3 EMG channels. I hope not to have problems..

Thank you so much for your help!
Have a good day!
Giulia

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: 3 gtec, too slow!

Post by boulay » 24 Jul 2014, 12:07

Oh right I forgot about the amp versions! Sorry about that. You can use two different versions but you need a special cable (which they have at the Ushiba-lab). Anyway, it is simpler to use all the same version.

gcisotto
Posts: 12
Joined: 27 Nov 2013, 03:44

Re: 3 gtec, too slow!

Post by gcisotto » 26 Jul 2014, 21:15

Thanks Chad, now it is seemed to properly work!
But I didn't know about the special cable to connect two different kind of amplifiers, thanks!

Have a nice Sunday!
Giulia

Locked

Who is online

Users browsing this forum: Google [Bot] and 1 guest