Question about using OpenBCI for a P3Speller task

Known Issues and Problems with BCI2000
Post Reply
lisapelagalli
Posts: 2
Joined: 11 Nov 2018, 10:39

Question about using OpenBCI for a P3Speller task

Post by lisapelagalli » 11 Nov 2018, 11:09

Hi everyone,

I'm working for my thesis with OpenBCI Cyton board and I want to use BCI2000 for a P3Speller task. I notice that the sample rate is 250 Hz by default, and the sample block size is 125 Hz, because it sends data to buffer every half second. So the minimum value for "Stimulus Duration" is 500 ms that is not a good value for a P300 based application! When I try to modify the settings, it comes an error about the fact that it wants to take the automatic settings.
What could I do? Should I work on the firmware?
Please, give me some advices.

mellinger
Posts: 1035
Joined: 12 Feb 2003, 11:06

Re: Question about using OpenBCI for a P3Speller task

Post by mellinger » 14 Nov 2018, 10:06

Hi,

the buffer duration of 500ms is a limitation of the OpenBCI firmware.
So yes, you would need to modify the firmware if you want to perform P300 experiments using OpenBCI.

Regards,
Jürgen

lisapelagalli
Posts: 2
Joined: 11 Nov 2018, 10:39

Re: Question about using OpenBCI for a P3Speller task

Post by lisapelagalli » 06 Dec 2018, 07:38

Hi,
thank you for the advice. I solved the problem by changing the sample block size on the source code.
Now I have another problem: after using the P3Speller, I notice that the data I save are all zeros. This is not true using the OpenBCI Gui to stream the data.

Which could be the reason?
Regards,
Lisa Pelagalli

madamek
Posts: 1
Joined: 06 Dec 2018, 09:27

Re: Question about using OpenBCI for a P3Speller task

Post by madamek » 06 Dec 2018, 13:21

Hi,
could you send me the parameter files you used, so I can try to replicate the behavior?
Just pm me a dropbox folder or similar, thank you,

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest