App connector problem

Forum for discussion on different user applications
Locked
magicmetalband
Posts: 1
Joined: 19 Oct 2010, 16:37

App connector problem

Post by magicmetalband » 19 Oct 2010, 16:43

Hi,

I'm working on visualization of brain signals and decided to write a simple external application. User will be supposed to move a ball right/left using his signals. For program to work, I read UDP packets containing control signal sent via App Connector. I use a training example, "CusrosTask_SignalGenerator.bat", with all the parameters loaded from files shown in tutorial. I get the following from UDP:
------------------------------

Code: Select all

Running 0
0.0581874

Recording 1
0.0581874

SourceTime 56699
1874

StimulusTime 56704
74

TargetCode 2
56704
74

ResultCode 0
56704
74

Feedback 1
0
56704
74

CursorPosX 332
704
74

CursorPosY 2053
04
74

CursorPosZ 2047
04
74

Signal(0,0) 2
7
04
74

Signal(1,0) -0.0701226
(and so on...)

--------------------------------
When I move my mouse around, I see Channel 1 & 2 amplitudes change. However, I cannot see any connection between mouse position and what I get in UDP. Signal(0,0) is always "2" and Signal(1,0) is not the signal I see on Channel 1 or 2.

How do I aquire signal data for an external app? Is the method I'm using good for my purpose?

Best regards

jawilson
Posts: 109
Joined: 28 Feb 2005, 16:31

Post by jawilson » 20 Oct 2010, 07:17

What program are you using to acquire the UDP packets? Is it Matlab, a C++ program, or something else? Also, can you post a code snippet of where you read from UDP?
Thanks!

gschalk
Posts: 615
Joined: 28 Jan 2003, 12:37

Cursortask

Post by gschalk » 20 Oct 2010, 08:06

Hi,

If you use the CursorTask_SignalGenerator.prm parameter file, signals (0,0) and (1,0) should definitely reflect the size of the sine waves on channels 1 and 2, which in turn is modulated by the mouse.

Gerv

Locked

Who is online

Users browsing this forum: No registered users and 1 guest