UDP-Communication with e-Prime 2.0

Forum for discussion on different user applications
Post Reply
emanuellorenz
Posts: 8
Joined: 21 Aug 2019, 07:47

UDP-Communication with e-Prime 2.0

Post by emanuellorenz » 04 Sep 2019, 06:25

Hi,
I have a question concerning the AppConnector. I tried a lot before and read through this forum and the documentation, but I think it's time. So I*m using following setup:

Source: AmpServerPro
Operator: v.3.0.5
Filter: FieldTripBuffer
Application: DummyApplication

External Stimulus Software: e-Prime 2.0

So everything works surprisingly fine, except the UDP-connection between e-Prime and the AppConnector. e-Prime is sending a state (stimulus onset and offset) as string (littleEndian), like

Code: Select all

Trigger 1\n
to the AppConnector running on a different system. I do receive this trigger as WireShark and the BCI2000Shell show, but I also get the error that the input is malformed. In the batch I also create a state (8-bit) with the same name as the send one.

Code: Select all

Wait for Connected
Load parameterfile "../parms/NU_BCI_Test_3.prm"
ADD STATE Trigger 8 0 0 0
Set config
I tried

Code: Select all

ADD WATCH Trigger AT 10.0.0.41:20230
but the command seems to be unknown.

I probably oversee something. But what?

All the best,

Emanuel

emanuellorenz
Posts: 8
Joined: 21 Aug 2019, 07:47

Re: UDP-Communication with e-Prime 2.0

Post by emanuellorenz » 05 Sep 2019, 05:25

Never mind.... I used the wrong port...

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest