BCI2000 and Emotive Epoc

Forum for discussion on different signal processing algorithms
Locked
sebastian_s
Posts: 2
Joined: 16 Apr 2014, 04:59

BCI2000 and Emotive Epoc

Post by sebastian_s » 07 Jun 2014, 02:07

Hi everyone,

I'm using the Emotiv Epoc to design a general purpose interface between a BCI system and virtual reality. One of the requirements is that the system is usable within BCI2000, so I would need to setup BCI2000 with Epoc-support.

I already downloaded the BCI2000 source and built it using MSVC2010 (Service Pack 1) on a Windows 7 64bit machine.
Everything went fine in the first place and all sample modules are running well except the Source-Module for the Epoc itself. After hitting "Start" the pipeline runs a few seconds, then getting stopped by a 0xc0000005 Win32 Exception (Access Violation).

I already tried to debug the module, without success, it seems the error is getting thrown in the system itself.

Has anyone already set-up a working system with the Epoc? I would be glad to get some system specs to mirror it because i really need to get this working.

PS: I was able to replicate the error on another system with the same specs.

Thanks in advance,
Sebastian

sebastian_s
Posts: 2
Joined: 16 Apr 2014, 04:59

Re: BCI2000 and Emotive Epoc

Post by sebastian_s » 11 Jun 2014, 04:03

Hi everybody,

in case someone has the same issue: i solved the problem myself using pre-built binaries for the emotiv source-module. Since i encounterd compatibility issues between pre-built contrib-distributions and the system built from source, i think maybe an update is required for the epoc's source module.

Thanks,
Sebastian

Locked

Who is online

Users browsing this forum: No registered users and 1 guest