Switching between NIDAQ boards

Forum for software developers to discuss BCI2000 software development
Locked
zackwright
Posts: 2
Joined: 07 Apr 2011, 16:36

Switching between NIDAQ boards

Post by zackwright » 12 Apr 2011, 14:00

I simply want to switch between a NIDAQ PCI board to a NI USB-6229 board (currently using NIDAQ_mx_source for the source code and NIDAQmx 9.2.2 driver). However, this has been a difficult process. After setting the configuration, the program seems to run fine and there are clear EMG signals on the signal source. Suddenly, after about 10 seconds, the signals wipeout (converges to zero), but continue to run, without any indication of warning signs/errors. If I restart the program, I just get a flatline on all the channels, but the program still runs. The only way to get any signal is if I restart the NIDAQ board, but after ~10s the same thing occurs.

I figured that there might be a problem with the computer being able to read in data, but I have tried the device on another computer. Then I thought there may be something wrong with the NIDAQ board, but it seems to work fine with other programs (i.e. LabView).

It seems that there might be either a compatibility issue or configuration issue. I am fairly new to BCI2000, so I hoping someone could point me in the right direction in resolving this issue. Is there something I need to change in the source code? configuration window? Am I using the right driver?

Zack

Locked

Who is online

Users browsing this forum: No registered users and 1 guest