about Build System

Forum for software developers to discuss BCI2000 software development
Locked
kiddnesta
Posts: 8
Joined: 04 Nov 2013, 22:09

about Build System

Post by kiddnesta » 07 May 2014, 23:41

I have donwload source from http://www.bci2000.org/svn/trunk
And change (USE_STD_QT FALSE) to (USE_STD_QT TRUE) in \source\build\cmake

\FindQT.
Then It's can built in VS2010.

I am built all BCI2000.sln in Release.
open the CursorTask_SignalGenerator.bat.

have a error about some entry points could not be found in QtCore4.dll


win7 64bit
VS2010
cmake 2.83
SVN
qterr.png
Last edited by boulay on 11 May 2014, 20:59, edited 2 times in total.
Reason: Placed figure inline

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: about Build System

Post by boulay » 11 May 2014, 21:05

Did you try running "Make VS10 Project Files.cmc"?

That launches the Configure.sh.cmd script which, among many things, downloads a static Qt that BCI2000 is developed against. The method you described SHOULD work, but maybe the version of Qt you have on your system is incompatible, or maybe there's a problem with localization settings somewhere.

kiddnesta
Posts: 8
Joined: 04 Nov 2013, 22:09

Re: about Build System

Post by kiddnesta » 11 May 2014, 21:10

This problem has been resolved. :D

I have download qt-opensource-windows-x86-vs2010-4.8.6.exe, and built in VS2010.
Than built BCI2000 in VS2010. It's OK.

But have a new problem.
I hve run CursorTask_SignalGenerator.bat,
"2014-05-12T09:10:02 - StateMachine::EventLink::OnExecute: EventLink: Could not open UDP port 4000 for listening"

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: about Build System

Post by boulay » 11 May 2014, 21:29

Are you trying to use AppConnector? I'm not sure why there'd be a UDP port being used otherwise.

kiddnesta
Posts: 8
Joined: 04 Nov 2013, 22:09

Re: about Build System

Post by kiddnesta » 11 May 2014, 21:44

Run the BCI2000Launcher,and choose any modules to Launch, the problem is occured.

After configuring BCI2000, this result is occured.

Code: Select all

error opening key: Software\Microsoft\VisualStudio\10.0\vsmacros\OtherProjects7
error opening key: Software\Microsoft\VisualStudio\10.0\vsmacros\RecordingProject7

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: about Build System

Post by boulay » 11 May 2014, 21:56

I don't think those cmake errors have anything to do with the UDP errors.

Are you running BCI2000 with an administrator account? BCI2000 uses network protocols (I thought it was TCP, not UDP) to communicate between modules. You have to set your firewall to allow each of BCI2000's executables. Normally a firewall exception warning pops anytime you run a BCI2000 module for the first time. Were you getting those?

kiddnesta
Posts: 8
Joined: 04 Nov 2013, 22:09

Re: about Build System

Post by kiddnesta » 11 May 2014, 23:29

I try to built in winxp.
And have a problem.
In Programming Reference:Building Qt for BCI2000.
"Open the file qt/projects.pro, and put a comment sign in front of "examples demos" near the top of the file. "
Where is the near the top of the file?

Code: Select all

#####################################################################
# Main projectfile
#####################################################################

CONFIG += ordered
TEMPLATE = subdirs

cross_compile: CONFIG += nostrip

isEmpty(QT_BUILD_PARTS) { #defaults
    symbian|integrity {
       QT_BUILD_PARTS = libs tools examples demos
    } else {
       QT_BUILD_PARTS = libs tools examples demos docs translations
    }
} else { #make sure the order makes sense
   contains(QT_BUILD_PARTS, translations) {
       QT_BUILD_PARTS -= translations
       QT_BUILD_PARTS = translations $$QT_BUILD_PARTS
   }
   contains(QT_BUILD_PARTS, tools) {
       QT_BUILD_PARTS -= tools
       QT_BUILD_PARTS = tools $$QT_BUILD_PARTS
   }
   contains(QT_BUILD_PARTS, libs) {
       QT_BUILD_PARTS -= libs
       QT_BUILD_PARTS = libs $$QT_BUILD_PARTS
   }
   contains(QT_BUILD_PARTS, qmake) {
       QT_BUILD_PARTS -= qmake
       QT_BUILD_PARTS = qmake $$QT_BUILD_PARTS
   }
}

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: about Build System

Post by boulay » 12 May 2014, 21:31

You shouldn't need to build Qt if you used Make VS10 Project Files.cmc (or the script for your version of Visual C++) because that script will download a precompiled static Qt library for you.

If you insist on building Qt yourself then which version of Qt are you using?

kiddnesta
Posts: 8
Joined: 04 Nov 2013, 22:09

Re: about Build System

Post by kiddnesta » 12 May 2014, 21:32

I knew this error.


2014-05-12T09:10:02 - StateMachine::EventLink::OnExecute: EventLink: Could not open UDP port 4000 for listening

because I opened QQ(Chat Software), QQ use UDP port 4000.

:(

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: about Build System

Post by boulay » 12 May 2014, 22:22

Searching through the archives, it seems someone else (I guess also in China) encountered this same error previously.
http://www.bci2000.org/phpbb/viewtopic.php?f=8&t=1339

Maybe (s)he also used the QQ chat client. Is the problem resolved if you close QQ and all of its services before launching BCI2000?

Another thing you can do is to change the port BCI2000 uses to connect the modules. This can be done with operator scripting or maybe you can do it with BCI2000Launcher (I'm not on a windows box right now so I can't test).

kiddnesta
Posts: 8
Joined: 04 Nov 2013, 22:09

Re: about Build System

Post by kiddnesta » 12 May 2014, 22:39

close QQ -》Lauch
It's OK.

About "change the port BCI2000 uses to connect the modules".
I will try to do later.

This problem is Chinese characteristics!

Locked

Who is online

Users browsing this forum: No registered users and 1 guest