Amplifier

Forum for software developers to discuss BCI2000 software development
Locked
khosravifard
Posts: 11
Joined: 30 Dec 2012, 10:02

Amplifier

Post by khosravifard » 08 Nov 2013, 17:53

Hi,
I have a question regarding to amplifier for BCI2000,I want to know if there is any special amplifier for BCI2000 or it is possible to use the amplifier which is connected to Net Station and provide signals to BCI2000?

Best Regards,
Mina

mellinger
Posts: 1052
Joined: 12 Feb 2003, 11:06

Re: Amplifier

Post by mellinger » 11 Nov 2013, 08:34

Hi,

if you have an AmpServerPro SDK license, you will be able to use an EGI amplifier connected to NetStation. Note that the current version of the AmpServerPro module is broken but we are working on this together with EGI to make it work again.
If you need to use BCI2000 right now, you should use the 3.0.5 binaries which may be downloaded from here:
http://bci2000.org/downloads/bin/BCI2000Contrib.exe

Regards,
Juergen

khosravifard
Posts: 11
Joined: 30 Dec 2012, 10:02

Re: Amplifier

Post by khosravifard » 15 Nov 2013, 09:03

Hi Dear Juergen,
I want to see the result of an experiment from the BCI2000 and NetStation separately at the same time,as you said BCI2000 will connect to the amplifier through the NetStation but does it interfere with results( result of BCI2000 and NetStation separately ) when BCI2000 is connected to the amplifier through the NetStation.

As you said that I can use the binaries 3.0.5,I should mention that I wrote my own application in BCI2000 3.0.5 using BCI2000Connection and BCI2000Remote and if I want to use the version that you said are these files (BCI2000Connection and BCI2000Remote) different from those I used?

If I should wait until AmpServerPro get ready to use would you please tell me how long I should wait?

Best Regards,
Mina

mellinger
Posts: 1052
Joined: 12 Feb 2003, 11:06

Re: Amplifier

Post by mellinger » 25 Nov 2013, 08:46

Hi,

after getting feedback from EGI, last week I checked in a bug fix to the AmpServerPro source module. Lacking access to an EGI amplifier myself, I was not able to confirm that it works now, but you should give it a try by updating your source code to the latest SVN version.

Otherwise, to avoid interference with your setup, consider downloading the 3.0.5 release from the BCI2000 website, install/extract it to a new directory, and move the AmpServerPro source module from there over into the BCI2000 directory from where you are running your experiments.

Regarding interference between BCI2000 and NetStation, there shouldn't be any as far as I understand the AmpServerPro documentation provided by EGI.

Best regards,
Juergen

khosravifard
Posts: 11
Joined: 30 Dec 2012, 10:02

Re: Amplifier

Post by khosravifard » 10 Dec 2013, 06:25

Hi Dear Juergen,
thanks for your reply.
I have downloaded BCI2000 source code through the latest version of SVN,when I checked the reversion date, I understood the reversion backed to 23 May. Is this a fixed version without bug? (the one you mentioned in your last reply) If not ,could you please update the source code?

Kind regards,
Mina

Locked

Who is online

Users browsing this forum: No registered users and 1 guest