P3Speller not outputting "P3Speller_Output"

Forum for software developers to discuss BCI2000 software development
Locked
jfornasin
Posts: 2
Joined: 20 Dec 2011, 05:52

P3Speller not outputting "P3Speller_Output"

Post by jfornasin » 04 Nov 2013, 11:36

Hi all,

I wrote a Python script to listen to the socket where the P3Speller would write its output. I edited the matrix to be a 3x3 one with these associations:

( Dispaly, Enter )
1 ( , 0 )
2 ( Avanti, avanti )
3 ( , 0 )
4 ( Girasx, girasx)
5 ( , 0 )
6 ( Giradx, giradx )
7 ( , 0 )
8 ( Indietro, indietro )
9 ( , 0 )

I ran a session with mouse click selection. The script listened to the socket for 30 seconds but, despite 4 successful selections, not a single "P3Speller_Output"-type output was written in the socket. Instead I found in the log file of my script output of this form:

Running 1

Recording 1

SourceTime 483

StimulusTime 491

The summary written by P3Speller at the end of the session reports correctly the 4 selections.

Where am I wrong? ^^'

mellinger
Posts: 1065
Joined: 12 Feb 2003, 11:06

Re: P3Speller not outputting "P3Speller_Output"

Post by mellinger » 11 Nov 2013, 08:39

It seems you are reading from the UDP port used by the AppConnector to write its data to.
You should make sure that the P3Speller uses a different UDP port than the one specified in the ConnectorOutput parameter.

Regards,
Juergen

jfornasin
Posts: 2
Joined: 20 Dec 2011, 05:52

Re: P3Speller not outputting "P3Speller_Output"

Post by jfornasin » 11 Nov 2013, 13:45

Thank you very much! It helped a lot!

Locked

Who is online

Users browsing this forum: No registered users and 1 guest