Script error Could not run "gUSBampSource"

Forum for software developers to discuss BCI2000 software development
Locked
xawen
Posts: 3
Joined: 12 Nov 2012, 15:19

Script error Could not run "gUSBampSource"

Post by xawen » 29 Mar 2013, 20:33

hello everyone,

After buliting BCI2000 using Cmake 2.8.3, I got into trouble about gUSBampSource when I followed the "Mu Rhythm BCI Tutorial" to perform an initial session to acquire BCI configuration parameters. every time after I double-clicking StimulusPresentation_gUSBamp.bat,there will be a warning just as follow or the attachment :

Script error: D:\BCI2000\batch\StimulusPresentation_gUSBamp.bat, line 33: Could not run "gUSBampSource"

Does anybody know what's the problem is ? and how to deal with it ?

Regards,
xa
Attachments
the screenshot of the error.
the screenshot of the error.

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: Script error Could not run "gUSBampSource"

Post by boulay » 30 Mar 2013, 08:25

xa,
Unfortunately I can't get enough information from that screen shot.

Can you open a command prompt (click on the start button, then type "cmd", then click on the command prompt icon),
then

Code: Select all

D:
cd /BCI2000/prog
dir
and make sure you have both gUSBampSource.exe and gUSBampgetinfo.exe in that folder?
If both files are there, try running gUSBampgetinfo.exe and then let us know what the output is.

Does the gUSBamp Demo application work (installed when you installed the drivers)?

xawen
Posts: 3
Joined: 12 Nov 2012, 15:19

Re: Script error Could not run "gUSBampSource"

Post by xawen » 30 Mar 2013, 23:28

boulay

I make sure that gUSBampSource.exe and gUSBampgetinfo.exe exit in the folder .

After running gUSBampgetinfo.exe,the output is a warning in Chinese:"出现了一个问题,导致程序停止正常工作。如果有可用的解决方案,windows 将关闭程序并通知您。" .Translate these words in English is "there is a problem ,lead to an unormal stop .if there is a solution ,windows will close the procedure and inform you !"

The gUSBamp Demo application work well.
in the attachment is three screenshot .
what the possible problem is ?
Attachments
cmd.png
g.USBampgetinfo.jpg
g.USBamp Demo.jpg

boulay
Posts: 382
Joined: 25 Dec 2011, 21:14

Re: Script error Could not run "gUSBampSource"

Post by boulay » 30 Mar 2013, 23:57

Sorry, I meant you should try running gUSBampgetinfo from within the command prompt in case it gave you a more useful error, but probably not in this case.

Try using the precompiled executables:
http://bci2000.org/downloads/bin/BCI2000Setup.exe
You will need your BCI2000 username and password to download it.

These precompiled executables are 32-bit. If you want to run them on a 64-bit system, you will need to place the 32-bit gUSBamp.dll file into C:\Windows\SysWOW64

xawen
Posts: 3
Joined: 12 Nov 2012, 15:19

Re: Script error Could not run "gUSBampSource"

Post by xawen » 31 Mar 2013, 08:10

boulay

My system is 32bit ,after trying the precompiled executables from the "http_nospam_bci2000.org/downloads/bin/BCI2000Setup.exe",The BCI2000 in my computer runs well now !
thanks for your patient and detailed answers!
best regards,
xa

Locked

Who is online

Users browsing this forum: No registered users and 2 guests