Could not connect to operator module !!

Forum for software developers to discuss BCI2000 software development
Locked
ahalharbi
Posts: 5
Joined: 14 Nov 2011, 02:32

Could not connect to operator module !!

Post by ahalharbi » 21 Nov 2011, 15:25

Dear BCI2000 programmers,
I am trying to run BCI2000 using C++ builder XE2. When I run the program an error massage is appear:
SingleProcessing:Could not connect to operator module. :!:

How can I solve this problem.
I relay need your help.

I am using windows vista
64-bit

Waiting your replay..

Thanks,
Amal Alharbi

mellinger
Posts: 1065
Joined: 12 Feb 2003, 11:06

Re: Could not connect to operator module !!

Post by mellinger » 22 Nov 2011, 08:28

Hi,

C++ Builder cannot be used to build the BCI2000 Operator module. Thus, when building BCI2000 with C++ Builder, the operator module is not built, and will be missing when you try to start up your compiled BCI2000.

In order to get an Operator module, you need to download a binary release (http://www.bci2000.org/wiki/index.php/B ... on_History), and move both Operator.exe and OperatorLib.dll from the binary release's prog directory into your BCI2000 prog directory.

Regards,
Juergen

ahalharbi
Posts: 5
Joined: 14 Nov 2011, 02:32

Re: Could not connect to operator module !!

Post by ahalharbi » 22 Nov 2011, 17:39

Thanks Juergen.
I did exactly what u said before but still a have the same problem :(
any other solution :?:

mellinger
Posts: 1065
Joined: 12 Feb 2003, 11:06

Re: Could not connect to operator module !!

Post by mellinger » 23 Nov 2011, 07:14

In case I'm guessing correctly that you want to run a BCI2000 module inside the debugger, this might help:
http://www.bci2000.org/wiki/index.php/P ... #Debugging

Locked

Who is online

Users browsing this forum: No registered users and 1 guest