Search found 9 matches

by skvpe
09 Jan 2015, 21:18
Forum: Software Development
Topic: New Source module problem
Replies: 2
Views: 1656

New Source module problem

Hi, I am implementing a custom signal source to get and display data from the usb. The new signal source is using BufferedADC. In there I found that I have to declare all the functions to open/close USB device in the DoAcquire() function. If I split these declarations in multiple functions then I ge...
by skvpe
22 Dec 2014, 22:36
Forum: Configuration
Topic: problem with new filter
Replies: 1
Views: 1783

Re: problem with new filter

Hello,

Can anyone please see into this and help find/share the solution of this problem? In my code I get this error when I use Dummy processing and dummy application.

BCI2000 is just giving one error after the another :(
by skvpe
01 Dec 2014, 00:33
Forum: Known Issues
Topic: Error during BCI2000 setup
Replies: 12
Views: 9042

Re: Error during BCI2000 setup

I tried some FindQT found on github but did not work. But the problem got solved after reinstalling everything from scratch.
by skvpe
28 Nov 2014, 21:37
Forum: Known Issues
Topic: Error during BCI2000 setup
Replies: 12
Views: 9042

Re: Error during BCI2000 setup

Hi guys, I am stuck in the same problem - BuildVS2010.cmd file searches online for Qt 4.8.6, but I already precompiled binaries installed on a PC which has no internet. In FindQT.cmake, I cannot find the above lines (setting False to True), which part can I edit to make sure cmake finds installed QT...
by skvpe
24 Nov 2014, 01:17
Forum: Known Issues
Topic: 0xc0000005 :(
Replies: 10
Views: 7153

Re: 0xc0000005 :(

Hi Guys,

Did anyone find the exact cause of this error? I tried everything listed here but the error did not go away.
by skvpe
18 Nov 2014, 21:51
Forum: Configuration
Topic: Missing LIB files. BCI2000 + Visual Studio
Replies: 5
Views: 3205

Re: Missing LIB files. BCI2000 + Visual Studio

That solved the issue. I just had to remove 'const' from declaration of preflight in few header files to make that work.

Thanks!
by skvpe
18 Nov 2014, 00:51
Forum: Configuration
Topic: Missing LIB files. BCI2000 + Visual Studio
Replies: 5
Views: 3205

Re: Missing LIB files. BCI2000 + Visual Studio

Hi bouley, The problem was cmake put these lib files in src->build->CmakeFiles->Frameworks folder whereas the compiler was accessing src->build->cmake->frameworks folder. So I had to copy files to this folder to remove the error. Currently when I run this code as signal source, I get another error a...
by skvpe
12 Nov 2014, 18:40
Forum: Configuration
Topic: Missing LIB files. BCI2000 + Visual Studio
Replies: 5
Views: 3205

Re: Missing LIB files. BCI2000 + Visual Studio

Hello,

Thanks a lot for your reply. I did try as you recommended. But build fails due to those missing lib files. I will try installing latest version again..

Thanks for libusb code!
by skvpe
11 Nov 2014, 03:14
Forum: Configuration
Topic: Missing LIB files. BCI2000 + Visual Studio
Replies: 5
Views: 3205

Missing LIB files. BCI2000 + Visual Studio

Hello, I am a beginner in BCI2000 environment and I request your help in the following issue. I am running BCI2000 in MS Visual Studio 2010 and I followed the instructions given in wiki. I got BCI2000.sln as mentioned there and was able to build all and generate exe files for all projects. Next I wa...