Search found 8 matches

by jpardo
08 Dec 2011, 12:09
Forum: Software Development
Topic: Matlab engine and C++
Replies: 4
Views: 3568

Re: Matlab engine and C++

I came up with another solution based on some stuff that I read online about Matlab R2011a. Basically, I switched my version of Matlab to 32-bit (since I'm using a 32-bit compiler), but in addition I added the directory C:\Program Files (x86)\MATLAB\R2011a\bin\win32 to my path variable by going into...
by jpardo
06 Dec 2011, 17:41
Forum: Software Development
Topic: Matlab engine and C++
Replies: 4
Views: 3568

Re: Matlab engine and C++

Hey Adam, Thanks for the tip. The MatlabWrapper got me past that error and everything compiles now. However,I'm running into another problem. Every time, I run my code and the MatlabEngine::Open() is executed, the function fails to find libeng and an error "Could not load library libeng" is reported...
by jpardo
02 Dec 2011, 15:13
Forum: Software Development
Topic: Matlab engine and C++
Replies: 4
Views: 3568

Matlab engine and C++

Hi, I'm looking to include the matlab engine in my C++ program. Simply including engine.h does not seem to work and I keep getting an Error 1 error C2371: 'char16_t' : redefinition; different basic types on MSVC 2010. What are the instructions to include the matlab engine appropriately? I noticed th...
by jpardo
01 Dec 2011, 16:46
Forum: Software Development
Topic: New Module Compilation Problems
Replies: 8
Views: 6115

Re: New Module Compilation Problems

Hi Juergen, Yes, you're right, the messages are from the debugger. I was a bit confused on what they meant. Anyway, I discovered that my problem with QImage is unique to Qt 4.6 the image support for jpeg using the Qt plug-in ( http://developer.qt.nokia.com/forums/viewthread/320 ). Apparently the pro...
by jpardo
23 Nov 2011, 15:18
Forum: Software Development
Topic: New Module Compilation Problems
Replies: 8
Views: 6115

Re: New Module Compilation Problems

Hi Juergen, I completely agree with you and understand what CMake is doing now. I fixed my problem by NOT adding files using the IDE and just letting Cmake build the solution using the files I added to the src directory. It was a bit confusing for me because I would add files using the IDE and then ...
by jpardo
22 Nov 2011, 16:37
Forum: Software Development
Topic: New Module Compilation Problems
Replies: 8
Views: 6115

Re: New Module Compilation Problems

Thanks for replying! I started again from scratch carefully following the quickstart guide and got my code up and running again, however, I'm still not quite where I want to be. I ran into the following issues: 1) Every time I run CMake, the new build solution erases the files I've added to my proje...
by jpardo
18 Nov 2011, 15:39
Forum: Software Development
Topic: New Module Compilation Problems
Replies: 8
Views: 6115

New Module Compilation Problems

Hi, I'm trying to create a new application module for BCI2000. I used the NewBCI2000Module.exe utility and created a solution file for Microsoft Visual Studio 2010. Right after I create it it compiles with no problems. However, when I add blank .cpp and .h files to my project, it fails to compile. T...
by jpardo
06 Oct 2011, 12:01
Forum: Software Development
Topic: Sigfried Compilation Problems
Replies: 1
Views: 1451

Sigfried Compilation Problems

Hi. I'm new to BCI2000 and I'm trying to compile the Sigfried module. I understand that you need the Borland C++ 6 compiler to build Sigfried, however, everytime I try to build I get an error [C++ Error] Environment.h(455): E2166 Destructor for 'EnvironmentExtension' is not accessible. Any clues on ...