Search found 19 matches

by lsegura003
28 Dec 2016, 06:13
Forum: Data Analysis
Topic: High energy in low frequencies on awake users.
Replies: 0
Views: 955

High energy in low frequencies on awake users.

Hello, first of all i am not sure if the term "energy" is the most correct here, so i will clarify that it refers to a normal lecture ^2 at each sample. in the data i am about to show i was trying to analyse the cerebral activity of a subject in different frequency ranges. The way i did this, was ge...
by lsegura003
07 Dec 2016, 09:11
Forum: Software Development
Topic: Interest of module to show cerebral activity of delimited band frequencies
Replies: 0
Views: 4753

Interest of module to show cerebral activity of delimited band frequencies

Hello, i have been developing a couple of modules for BCI2000 which could be of use for someone. One of them involves P300 experiment but instead of trying to predict a character, it predicts a movement reflected in the movement of a little man in a 2d animation. This is more like a curiosity that c...
by lsegura003
10 Nov 2016, 05:15
Forum: Configuration
Topic: Operator module configuration. 3 state bar right from each parameter
Replies: 1
Views: 2032

Operator module configuration. 3 state bar right from each parameter

Hello,

i guess this question has been made before, but i am not able to find it through forums. When we click config in the operator module, we have like 3 selectable states at the right of each parameter. What are this for?

Sorry for the noobish question.
by lsegura003
28 Oct 2016, 09:03
Forum: Known Issues
Topic: Problem getting SampleRate with MatlabSignalProcessing module
Replies: 3
Views: 2123

Re: Problem getting SampleRate with MatlabSignalProcessing module

Ouch, you get me again!


I did it this way finally:

str=strjoin(bci_Parameters.SamplingRate);
B = regexp(str,'\d*','Match');
SampleRate= B{1}; %First number


Thanks man.
by lsegura003
27 Oct 2016, 09:27
Forum: Known Issues
Topic: Problem getting SampleRate with MatlabSignalProcessing module
Replies: 3
Views: 2123

Re: Problem getting SampleRate with MatlabSignalProcessing module

Sorry i did not mention it before, but i am using a compiled version of BCI2000 of the actual trunk source code. Perhaps it is related to the compilation not being done correctly? I do not think it is an error from the .m code i am using, it must come from BCI2000.
by lsegura003
26 Oct 2016, 09:24
Forum: Known Issues
Topic: Problem getting SampleRate with MatlabSignalProcessing module
Replies: 3
Views: 2123

Problem getting SampleRate with MatlabSignalProcessing module

Hello, in the initialize.m function for this module i use the next code: global bci_Parameters bci_States; global h_im h CH_N CH_MAP tamBloq; SampleRate= int8(str2double( bci_Parameters.SamplingRate)); tamBloq= int8(str2double( bci_Parameters.SampleBlockSize)); %Error 1 if(1==1) error( 'SampleRate %...
by lsegura003
20 Oct 2016, 13:45
Forum: Software Development
Topic: Matlabsignalprocessing module, incoming signal readings
Replies: 2
Views: 1103

Re: Matlabsignalprocessing module, incoming signal readings

As always, thanks a lot Peter!

I totally missed the transmitted channel field.
by lsegura003
20 Oct 2016, 11:15
Forum: Software Development
Topic: Matlabsignalprocessing module, incoming signal readings
Replies: 2
Views: 1103

Matlabsignalprocessing module, incoming signal readings

Hello, i am trying to apply my own filter to the signal obtained from BCI2000 with the MatlabSignalProcessing module. However i am not sure own how does the signal income work. Lets assume i have defined BlockSize=3 and ChannelNumber=4. This means that there are 4 channels transmiting and that there...
by lsegura003
13 Oct 2016, 07:55
Forum: Software Development
Topic: Questions about Matlab Filter
Replies: 0
Views: 6053

Questions about Matlab Filter

Hello, my first question is about matlab filter parameter definitions. In http://www.bci2000.org/wiki/index.php/Technical_Reference:Parameter_Definition there is this example for dataTypes as integer and float Section DataType Name= Value DefaultValue LowRange HighRange // Comment For example if i p...
by lsegura003
19 Sep 2016, 11:02
Forum: Known Issues
Topic: Building from source code with windows problem
Replies: 10
Views: 3108

Re: Building from source code with windows problem

Ok, i have tried something different. I built all the modules needed to run a test using the trunk source code, and seems now it is working. I guess, that for the 3.6 my confusion came from here: http://www.bci2000.org/wiki/index.php/Programming_Howto:Quickstart_Guide: You probably do not need to bu...
by lsegura003
15 Sep 2016, 19:05
Forum: Known Issues
Topic: Unknown CMake command "QT4_WRAP_CPP".
Replies: 2
Views: 1227

Re: Unknown CMake command "QT4_WRAP_CPP".

1) Use the pre-compiled static compilation of QT4 that is downloaded with setting up the build environment of 3.0.5. I do not know if i understand this. You mean not to use external ones? I use external ones because when i use the make VS2010 project files it is not able to download QT libraries. 2...
by lsegura003
15 Sep 2016, 18:44
Forum: Known Issues
Topic: Building from source code with windows problem
Replies: 10
Views: 3108

Re: Building from source code with windows problem

I did, indeed.

Result was this:

Unhandled Win32 exception of type ACCESS_VIOLATION (0xc0000005)
Terminating SignalGenerator module.
2016-09-15T13:25:40 - SignalSource error:
Lost connection to SignalSource.


When i pushed "start" button.
by lsegura003
15 Sep 2016, 11:29
Forum: Known Issues
Topic: Unknown CMake command "QT4_WRAP_CPP".
Replies: 2
Views: 1227

Unknown CMake command "QT4_WRAP_CPP".

Hey, First of all ,the software i am using for this is tortoiseSVN, to get 3.0.5 source code version at: http://www.bci2000.org/svn/tags/releases/current/ Visual Studio 2010 Express with SP1 Cmake 3.3.2 (altough i tried with other Cmake versions) Windows 7 32/64 bits (i try doing same things indepen...
by lsegura003
15 Sep 2016, 07:40
Forum: Known Issues
Topic: Building from source code with windows problem
Replies: 10
Views: 3108

Re: Building from source code with windows problem

Have built the stuff with the beta version source and it seemed it all was OK (downloaded all necessary software for it). Problem comes when i try to execute a built module (unchanged, so code is not problem) with precompiled ones. I built p3speller, which i run among precompiled signalgenerator and...
by lsegura003
13 Sep 2016, 13:42
Forum: Known Issues
Topic: Building from source code with windows problem
Replies: 10
Views: 3108

Re: Building from source code with windows problem

Seems that this new binaries solve the thing for me (in a 64 bit windows 7), i will try it in other computers and OS. I tried to execute it with anti-virus and firewall deactivated before and still got the same problem with the previous version (3.0.5). I am making "inter version" stuff tough (putti...